Jump to content
I2Cdevlib Forums

Recommended Posts

Hi friends,

I have managed to read from two mpu6050 on DMP. Both sensors are fitted on a piece of board and are perfectly levelled. 
My problem is that when I tilt the sensors such that I increase/decrease Roll, the Yaw is changed, even when the sensors are not rotated on the z axis. Is it normal that rolling affects yawing? Furthermore, the change in Yaw for both sensors is not the same, and there will be a difference in yaw of 8 deg between the two sensors for a 45deg rolling.

Thanks in advance,
Hatt

Link to comment
Share on other sites

Same strange problem here.

 

I had also another issue with interrupts and removed

while (!mpuInterrupt && fifoCount < packetSize) {}

in the sample file to get it running, because even after minutes no interrupt appeared. But afaik this have nothing to do with the roll/yaw problem?! Im using a Teensy 3.1 board.

Link to comment
Share on other sites

  • 3 years later...
  • 1 month later...

I am experiencing the same thing.

I don’t have a simple solution, but I have basically tracled it down to the yaw/pitch/roll algorithm.

What I have found is that if you stick purely with quaternions and do not switch to yaw pitch roll, the flipping problem goes away. At least it does in the processing “teapot” simulator.

My current issue is that I just don’t understand how to work with quaternions very well. Is anyone here well versed in quaternions?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...