Jump to content
I2Cdevlib Forums

MPU6050 aligned vertical with gravity along X - what to do?


Kailash
 Share

Recommended Posts

Hello,
 
I have been trying to find a solution for this issue for a while now. Any info/suggestion/pointing in the right direction would be of great help.
 
I am working on a project where I extract quaternions to deduce orientation using MPU6050 (DMP). I use the Arduino and libraries by Jeff Rowberg for calibration and reading from sensor. I have had a prototype working with MPU6050 mounted the standard way(gravity along Z) and it works fine.
 
I then built a custom PCB with MPU6050 chip, which is then assembled to my project. The difference being, PCB is assembled such that the gravity is not along Z, it is along X.
 
It doesn't work as I expected (like the initial prototype). When I turn on the device, I do some initial calculations to reference it (world to body coordinates conversion). This doesn't behave as I expect.
 
My questions are,
 
1. Does the DMP or library assume that the gravity is always aligned along Z by default? 
 
2. What steps should I follow to tell the DMP/Sensor that the gravity is aligned along X and not Z?
 
I am not an electronics guy and haven't worked extensively with sensors. So, if what I ask is stupid, please forgive me. Please do share your thoughts.
 
Many Thanks.
 
Kind Regards,
Kailash
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...