Jump to content
I2Cdevlib Forums

Help needed to run library under Arduino Due.


xchg-ca
 Share

Recommended Posts

  • 1 month later...
  • 2 years later...

Hi all,

 

TWBR is not my issue as I use Wire.setClock(400000). Code worked fine in Uno and Mega, but have been struggling the last days with no joy at all. My Due is an original one and even tried pull-up resistors though they shouldn't be needed in standard SDA/SCL. It just does not connect. I2C explorer utility does not work either. Any clue will be highly appreciated.

Link to comment
Share on other sites

Shame on me  :wacko:  :wacko:  :wacko: Beginner's mistake!!!

 

My Due has the pin headers labeled. I attached MP5060 to the first SCL/SDA pair I saw, assuming that SCL1/SDA1 (that I intend to use in the future, would be somewhere else. Nope. SCL/SDA are actually SCL1/SDA1: SCL/SDA are labeled as 21SCL and 20SDA. PCB shows the proper labeling. FIXED!! Sorry for bothering with this silly mistake, but for sure I've not been the first one, and not gonna be the last, either  :D .

Link to comment
Share on other sites

  • 3 weeks later...

Well... Bright side was bringing Wire to work. bit I'm failing miserably with Wire1. I can't even see the clock signal in SCL. I'getting some new level converters in a few days, but I suspect more from the soft than from the hard side. Any advise? Usual checks done: wiring, pull-up Rs, GND links,...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...