Jump to content
I2Cdevlib Forums

rbds

Members
  • Posts

    2
  • Joined

  • Last visited

rbds's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Update: I have no issues compiling and using this example on another computer. I am thinking that there is an issue with the libraries on my laptop. I have tried uninstalling and reinstalling Arduino, with no success. Does anyone know how to remove libraries from the Arduino IDE? Just deleting the folder doesn't seem to help, nor does uninstalling Arduino. Is there a configuration file hiding somewhere that the Arduino saves to and reads from? Any ideas or suggestions at what might have gone wrong would be appreciated.
  2. I am trying to get the MPU6050 example to compile and I can't seem to do it. I am using Arduino 1.0.5 on a Windows computer. So far, I have confirmed that the I2Cdev and the MPU6050 libraries are located in C:/Program Files (x86)/Arduino/Libraries. I have included the helper_3dmath library at the top of the example sketch, but I still cannot get it to compile. There is a long list of errors, but below are a couple. This seems to be an issue with the libraries I have included. C:\Users\Randy\Documents\Arduino\libraries\MPU6050/helper_3dmath.h: In member function 'float Quaternion::getMagnitude()': C:\Users\Randy\Documents\Arduino\libraries\MPU6050/helper_3dmath.h:74: error: 'sqrt' was not declared in this scope .... and: C:\Users\Randy\Documents\Arduino\libraries\MPU6050/MPU6050_6Axis_MotionApps20.h:596: error: 'class VectorInt16' has no member named 'x' C:\Users\Randy\Documents\Arduino\libraries\MPU6050/MPU6050_6Axis_MotionApps20.h:597: error: 'class VectorInt16' has no member named 'y' Please let me know if I am missing something obvious or if you will need more information to help. Thanks.
×
×
  • Create New...