Jump to content
I2Cdevlib Forums
Sign in to follow this  
SergioForster

Serious hardware issues with GY-521 modules

Recommended Posts

I have an  automotive development using MPU-6050 mounted on GY521 modules

I am driving the MPU-6050 using a  PIC24EP512GU806 Picmicro at 3.3v, 

For this reason I am bridging in the GY521 modules, the 5v to 3.3v regulator, since I have my own 3.3v regulator that powers my processor & MPU6050

They were very useful for this project the Jeff Rowberg libraries and examples, so I want to thank Jeff for this great work

I am using the MPU6050 DMP, with a sampling rate of 100 ms, which interrupts my processor every 100 ms to update Accel, Gyro, Quaternions, Euler angles, etc.

Now I tell you my problem, I have very serious hardware problems with the GY-521 modules

I bought 1500 units of gy-521 modules from two different Chinese suppliers, The price of gy-521 was very good, less than one dollar each per 1000 units

The appearance of these modules are identical to all I've seen in forum photos, each one in its bag, with the two connectors one straight and the other at 90 degrees.

They all seem to be from the same manufacturer, then sold by different vendors, they are even identical to the ones I bought locally during development

I have built a test tool, which connects to the gy-521 board with a clamp, does a calibration, and test with controlled movements in all axes, accel, gyros and DMP output from MPU6050

When I receive the modules, the first thing I do, is to remove the 5 to 3.3v LDO regulator, and make a bridge between pins 1 and 5 since my power supply is 3.3v.

The second thing I do is test them with my tool, during this test I am getting a rejection of 10% of the modules (they are new modules taken out from their bag)

The main reasons for rejection are: the DMP does not start, or any of the axes is fixed at a 2G value, no matter how the module moves.

then with the 90% approved modules, I assemble my equipment, test them and encapsulate them in epoxi resin

These equipments are then installed and calibrated in trucks, where they work 24 hours a day, measuring certain acceleration and incline parameters continuously, in an unattended eviroment

It is good to clarify that I have experience in both design of automotive equipment and unattended equipment, with adequate power supplies and intelligence and watchdog in the processor to recover from any software failure, with the capacity of a total ot partial power off, and automatic restart

The problem I am having is that after approximately 2 months of continuous good operation, the MPU6050 suddenly dies and stops working.

I cannot access to measure electrically since they are encapsulated in epoxy, but I see with the monitor leds , my processor trying to power off and restart continuously the MPU6050, I see also with a led that shows the status of the interrupt pin of the MPU 6050 that the DMP is not starting.

You know someone who has had similar problems, it will be counterfeit modules or mounted with scrap invensense chips?

Do you know any reliable vendor for these modules?

 

 

 

 

Share this post


Link to post
Share on other sites

Hi....They couldn't initialize and the problem was bad soldering of MPU6050 chip. So I tried to resolder it and it worked, but then it stopped, and I had to redo it again.I've ended up buying sole chips without pcb, because it seems for some reason they can't properly solder them.Or maybe it's just bad quality of counterfeit chips that are just working for their price.

seo toronto

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...