Jump to content
I2Cdevlib Forums

jaruj9

Members
  • Posts

    4
  • Joined

  • Last visited

jaruj9's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. I have the same problem with mpu6050 and arduino due, sometimes it connect and sometimes it does not.It happens also with dmp exampel from mpu6050 and I have no idea how to solve it! I would be really happy if someone could help us!!!!
  2. Hi guys, I come here, to ask you all nice people one tricky question.But for the beginning I will describe you my project which I am working on. My project is quadcopter, but not normal one, on board should be raspberry pi and arduino due with mpu6050. Basically everything works very well but not always. Here comes the problem. Sometimes Arduino DUE cant connect to mpu6050 over I2C. Sometimes it can and after restart of arduino DUE it again cant connect. Afterwards I have to power off arduino DUE and than power it again on. Than it works. So it looks to me some problem with registers or probably as I read, it can be with pull-ups on I2C. I was trying to repair it for a month but I could not, after lot of time I am trying to contact some person or group of people who could help me. I would be happy for all kinds of help. Here I am posting also my code on github and some pics of quadcopter. https://github.com/J...bzan/Quadcopter Little description of my project. On pc runs ground control written in C# which generates control strings and than sends them over network connection through sockets to raspberry pi, it executes them and then when necessary sends directly over serial to arduino DUE. Arduino DUE takes care for PIDs and sensors staff. When I use example dmp from i2cdevlib it happens the same.One I can next time I can not connect. Please I will be happy for all kind of help!
  3. Hi guys, I come here, to ask you all nice people one tricky question.But for the beginning I will describe you my project which I am working on. My project is quadcopter, but not normal one, on board should be raspberry pi and arduino due with mpu6050. Basically everything works very well but not always. Here comes the problem. Sometimes Arduino DUE cant connect to mpu6050 over I2C. Sometimes it can and after restart of arduino DUE it again cant connect. Afterwards I have to power off arduino DUE and than power it again on. Than it works. So it looks to me some problem with registers or probably as I read, it can be with pull-ups on I2C. I was trying to repair it for a month but I could not, after lot of time I am trying to contact some person or group of people who could help me. I would be happy for all kinds of help. Here I am posting also my code on github and some pics of quadcopter. https://github.com/JurajKabzan/Quadcopter Little description of my project. On pc runs ground control written in C# which generates control strings and than sends them over network connection through sockets to raspberry pi, it executes them and then when necessary sends directly over serial to arduino DUE. Arduino DUE takes care for PIDs and sensors staff. When I use example dmp from i2cdevlib it happens the same.One I can next time I can not connect. Please I will be happy for all kind of help!
  4. Hi guys! I come here with one question on I2Cdevlib, I love you work and your library it works perfectly! I would like to ask you, where am I able to understand how does DMP in your library works. Can you give me some source where can I learn it or maybe you can give us some explanation? I also would be interested in some information about XCL/XDA ports on the MPU6050 board. How can I configure them to work with magnetometer? Thank you so much for all answers!
×
×
  • Create New...